A.A.A.R. – Install A.A.A.R.

With this task you are going to install the A.A.A.R. Application into your environment. Below the description of the tasks to develop.

Access to Pentaho User Console as administrator (otherwise you will not have permits to access to configuration dashboards). Click on Tools -> AAAR.

AAAR_marketplace_1

Press the ‘Configure’ button.

AAAR_Install_3

Set the requested parameters and save the configuration. If you want you can check the configuration set in the file ‘<biserver-ce>/pentaho-solution/system/AAAR/endpoints/kettle/conf/AAAR_Configuration.xml’.

Press the ‘Install’ big button and install it using the ‘install’ button at the bottom of the page.

ATTENTION: This task creates two new database schema called AAAR_DataMart and AAAR_Kettle. Every installation invoked drop and re-create the two schemas.

AAAR_Install_4

Before going ahead, please check the log. The log is fully described in ‘<biserver-ce>/tomcat/logs/catalina.out’ or ‘<biserver-ce>/pentaho-solution/system/AAAR/endpoints/kettle/logs/AAAR.log’. Please, pay lot of attention because not all the error messages are real errors but you have to check everything has been properly executed to make all the solution works.

Before use the A.A.A.R., click on Tools -> Refresh -> CDA cache.

AAAR_Install_5

<< Get A.A.A.R. | Up to How-to install | Use A.A.A.R. >>

I like A.A.A.R.

29 thoughts on “A.A.A.R. – Install A.A.A.R.

  1. It’s great work. It’s what I’m looking for and perhaps i can contribute :). I try to install it with Alfresco CE 4.2.c but not yet successfull, from acces denied for user alfresco dan can’t find job : Get all. Following step by step your instruction but I get confused about the user and password. In this page, in table dm_dim_alfresco is login and password column match with the admin login to the Alfresco Explorer?
    I appreciate for your reply. Thank’s a lot.

    • Thank you spreilukis!
      Your contribution is definetely appreciated.
      Yes, login and password here are the Alfresco’s login and password used to retrieve the audit data. For the first connection I suggest you to use the administrator’s login but for a more correct approach you should use another user.
      Saying that, is your Alfresco’s installation replying to the 1121 port like the example describes?
      If not, discover which the correct port and change the ‘alfresco_port’ field in the table.
      If you have problems, write me privately and we’ll solve.

  2. Hello Francesco,

    I installed it via marketplace and the only thing I can see are the icons – there’s no Configure-, Install- & Use-Button. I couldn’t figure out, what’s the reason for this. I even tried different browsers.
    Maybe you know what’s responsible for this?

    Best regards
    Nicolai

      • Hi Francesco,

        Well, you do have to restart the server, before you can access AAAR, otherwise it is not listed in the “Tools”-Section. I restarted the server even several times by using the ctlscript.
        I’ve made a screenshot, I hope this improves the understanding of the problem. (http://abload.de/img/aaarffja2.jpg).
        I’m out of ideas, would be great if you had an idea.

        Best regards
        Nicolai

  3. Hi Nicolai,

    What you see is not correct!
    Seems to be an error on the installation process…
    I tried again in my development environments, with the last Pentaho releases, and everything seems to be correct.
    Please, check the catalina.out log file.
    Let me know in my private email and I’ll support you.

    • Ciao francesco,

      I was having exactly the same problem as Nicolai (no Configure-, Install- & Use-Button).
      Updating “Community Graphics Generator” and “Community Dashboards Framework” in the “installed plugins” tab and restaring pdi seem to have solved the problem for now.
      Buttons are back.

      Cheers

    • Ciao francesco,

      I was having exactly the same problem as Nicolai (no Configure-, Install- & Use-Button).
      Updating “Community Graphics Generator” and “Community Dashboards Framework” in the “installed plugins” tab and restaring pdi seem to have solved the problem for now.

      Buttons are back !

      Cheers

  4. Hello Franchesco,

    I installed everething necessary for AAAR on Ubuntu 12.10.
    Alfresco Community 4.2.e
    biserver-ce-5.0.1-stable
    pdi-ce-5.0.1.A-stable
    and AAAR 2.0 from Marketplace

    Audit turned on about two month ago.

    When I tried to do AAAR_Extract.sh I have got an error:

    2014/03/17 15:26:33 – Modified Java Script Value.0 – ERROR (version 5.0.1-stable, build 1 from 2013-11-15_16-08-58 by buildguy) : UnexpectedError:.
    2014/03/17 15:26:33 – Modified Java Script Value.0 – ERROR (version 5.0.1-stable, build 1 from 2013-11-15_16-08-58 by buildguy) : java.lang.OutOfMemoryError: Java heap space
    …………
    …………
    2014/03/17 15:26:34 – Kitchen – Processing ended after 2 minutes and 56 seconds (176 seconds total).

    all pdf files are empty.

    Can you help me?

    Regards, Ivan

    • Hi Robin,
      During the installation of the AAAR, two different databases are defined: AAAR_Kettle and AAAR_DataMart. The table ‘dm_dim_alfresco’ is a table stored in the AAAR_DataMart.

      • thanks for the help, but I cant edit the value of field desc. Based on your pdf manual.

  5. Hi Francesco,

    Do you have to install pentaho server separately from alfresco? As I see from the screen shot both are using port 8080.

    • Hi Julius,
      It is not mandatory to install Pentaho in a different server… but would be preferable for scalability.
      Of course if you choose to install Pentaho in the same Alfresco server, you have to pay attention to the tomcat’s port and conflicts in general.
      I hope this help you.

      • Thank you for the prompt response. I will follow your advise.

        I tried the latest version (2.1). Did not find it in the marketplace so I got it from sf. Using win 8.1 on a firefox browser, I seem to have an error when I try to open from tools > AAAR. It just keeps loading with the icon and gets stuck. Tried it on a win 7 using ie/chrome, I was able to load the configure, install and use pages but when I try to install using the button at the bottom of the page (described above) an error occurs. Resorted to manual installation instead. Now I am stuck on the “_pentahoUploads” file. From the log, I get “repository not created.” It seems that it does not upload the reports on the server or is this the purpose of the script? (Sorry but i am a novice in JAVA). If you could please help me resolve the error in my installation.

  6. Hi Julius,
    The most important issue is the Pentaho version.
    With Pentaho v5.0.0 or v5.0.1 the correct AAAR version is the v2.0.
    With Pentaho v5.1.0 the correct AAAR version is the v2.1.
    Thank to your comment, I discovered a problem on the Pentaho v5.0.1 version where the AAAR v2.0 is not presented as valid download. Tomorrow in the morning the problem will be solved.
    Until then, you can manually download the right version directly in sourceforge.
    Cheers.

  7. Ciao Francesco,

    In the step “1. Configure”, I set the database (MySql) :
    – type, host, port login,password
    – bin path : I:\mysql\bin (I’m on windows server)
    – pdi path : I:\pdi-ce-5.1.0.0-752\data-integration

    I save and then go to “2. Install” and click install

    I have the confirmation message telling everything went fine (and to refresh the CDA cache, which I do).

    But when I go to mysql I don’t have the new “AAAR_DataMart” and “AAAR_Kettle” created in the show databases command.
    The catalina.out is normal.
    The AAAR.log contains a single line saying “dummy”

    Any clue ?

    Grazie !

    • Hi again,

      this was due to an access not granted to mysql (pentaho.log showed me the error).
      Using mysql’s root user, it turned out good…

      Maybe there’s a security configuration missing on your documentation. In any case, the confirmation dialog pops saying Install is done, even when it failed creating the database…

      Cheers

      • Hi,

        Yes, sure… the errors are logged in the catalina.out.
        Did you installed the mysql as root?
        If yes, this is the problem because lot’s of installation has been developed with this approach (not only by me).
        Let us know how it goes… 😉

  8. 2. Install issue (chainging ports) :

    If you change the pentaho http ports to make them different from alfresco’s 8080, say you choose 8081 for bi server, then in the install procedure, at some point there’s an error because it tries to access a url with the 8080 port.
    Here’s an extract from the pentaho.log file :
    2014/08/01 16:27:38 – REST DELETE.0 – Can not result from [http://localhost:8080/pentaho/plugin/data-access/api/connection/deletebyname?name=AAAR_DataMart]
    2014/08/01 16:27:38 – REST DELETE.0 – java.net.ConnectException: Connection refused: connect

    to solve the problem I had to stick to orginal ports in pentaho and change alfresco’s…

    Any clue on how to fix this in pentaho (that is to say : how to properly override the default ports) ?

    grazie !

  9. Hello Francesco,

    I am having problems installing AAAR on Ubuntu 14.04.1, Pentaho 5.2, MySql and Java version “1.7.0_65”.

    The error log:

    2014/10/30 12:48:55 – _installMySql – Starting entry [Upload main]
    2014/10/30 12:48:55 – Upload main – Loading transformation from XML file [file:///opt/biserver-ce/pentaho-solutions/system/AAAR/endpoints/kettle/_pentahoUploads.ktr]
    2014/10/30 12:48:55 – _pentahoUploads – Dispatching started for transformation [_pentahoUploads]
    2014/10/30 12:48:55 – Create target folder and upload file.0 – ERROR (version 5.2.0.0, build 1 from 2014-09-30_19-48-28 by buildguy) : Error initializing UserDefinedJavaClass:
    2014/10/30 12:48:55 – Create target folder and upload file.0 – ERROR (version 5.2.0.0, build 1 from 2014-09-30_19-48-28 by buildguy) : org.codehaus.janino.CompileException: Line 11, Column 8: Imported class “org.pentaho.platform.web.http.api.resources.RepositoryImportResource” could not be loaded

    Tried to install it on Pentaho 5.1 also using Java 1.8, but I end up with the same problems. 😦

    Your help is much appreciated.

    Thanks

    • Hi Mark,
      You are the second user in the past couple o days that report me this problem… I’m going to check in my development environment and back to you with an answer.
      Please stay tuned… 🙂

      • Hi (again) Mark,
        I have just installed the AAAR v2.1 with Pentaho 5.2 on a Linux Ubuntu 14.04 LTS platform and everything it’s ok with the installation process.
        I have personally tested many times the AAAR with Pentaho 5.1 so… maybe something different is on your environment.
        Do you use a Windows environment?
        Please write privately to try to discover (and solve) your problem.

  10. I have just tested the installation in Windows environment… and it works correctly.
    Let us know some further details to understand (and solve) your problem.

Leave a Reply to Julien Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s