A.A.A.R. – Use A.A.A.R. – Analytics

With this task, the last but the most important, you have available for your users a real interactive dashboard into your Pentaho environment.

AAAR_Install_9

The dashboard and the reports could be completely customized for your needs (for example you could build your own reports or your own dashboards) and you could use it also as a linked resource from your external applications or your Alfresco.

To access to the main dashboard to analyze your data, you can: use the A.A.A.R. wizard, use the Pentaho repository at the path Home -> Browse -> Public -> AAAR -> Main (CDE), or access to the url described below:

http://<PentahoServer>/pentaho/api/repos/:public:AAAR:main.wcdf/generatedContent

All the access to the dashboards and reports are controlled by Pentaho authorities and protected by uncontrolled accesses.

Below a list of the incoming dashboards and analytics.

The dashboards below are available starting from the A.A.A.R. v2.2 ahead.

<< A.A.A.R. Publish     |     Use A.A.A.R.     |     A.A.A.R. Advanced Config >>

I like A.A.A.R.

13 thoughts on “A.A.A.R. – Use A.A.A.R. – Analytics

  1. Hi, i’ve followed this tutorial, but when i press the button “Analitycs” appears “Sorry. We really did try. Something went wrong. Please try again or contact your administrator” and the catalina log “ERROR [RepositoryResource] Repository file [:public:AAAR:main.wcdf] not found”

    can you help me? thanks in advance.

    • Hi Ricardo,
      The problem is for sure during the installation task.
      I suggest you to try again to install it, but please check the catalina log for problems or errors.
      Don’t worry to re-install it several times, the installation task always clean the environment. 😉

      • i did it and i find another error: Set variables – ERROR: syntax error at or near “EXTENSION”

        i’m so thankful by your help 🙂

  2. Hi Francesco,

    Is possible generate workflows reports? I see only reports for content and others. I need generate reports which I can see the number of workflows in execution, in due date, en atrasos, etc, Is possible with this tool? Any suggestion?

    Thanks for your time.

    Greetings,
    Pablo.

    • HI Pablo,
      With AAAR v2.1 I’m experimenting the solution.
      I’ll write you privately to suggest how to do it.
      If someone else is interested, please write me and we will test it in real cases.

  3. Hi, i have an error “ERROR [org.pentaho.platform.web.http.api.resources.RepositoryResource] Repository file [:public:AAAR:main.wcdf] not found”. I re-installed it many times, but it did not help.

      • Ok, i fixed it. Now i have next error…
        2014/09/30 11:04:22 – _installFromConfiguration – Starting entry [_pentahoAddDatasource]
        2014/09/30 11:04:22 – _pentahoAddDatasource – Loading transformation from XML file [file:///opt/biserver-ce/pentaho-solutions/system/AAAR/endpoints/kettle/_pentahoAddDatasource.ktr]
        2014/09/30 11:04:22 – _pentahoAddDatasource – Dispatching started for transformation [_pentahoAddDatasource]
        2014/09/30 11:04:22 – Data Grid.0 – Finished processing (I=0, O=0, R=0, W=1, U=0, E=0)
        2014/09/30 11:04:22 – Modified Java Script Value.0 – Optimization level set to 9.
        2014/09/30 11:04:22 – REST DELETE.0 – Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
        2014/09/30 11:04:22 – Select values.0 – Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
        2014/09/30 11:04:22 – Modified Java Script Value.0 – Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
        2014/09/30 11:04:23 – Abort.0 – ERROR (version 5.0.1-stable.148b6fef6a996547f0a83bc49a869d75ef55b8ca, build 1 from 2013-11-15_14-00-42 by buildguy) : Row nr 1 causing abort : [null], [{“changed”:true,”connectSql”:””,”databaseName”:”AAAR_DataMart”,”databasePort”:”3306″,”hostname”:”localhost”,”name”:”AAAR_DataMart”,”password”:”password”,”username”:”root”,”attributes”:{},”connectionPoolingProperties”:{},”extraOptions”:{},”accessType”:”NATIVE”,”databaseType”:{“defaultDatabasePort”:”3306″,”extraOptionsHelpUrl”:”http://dev.mysql.com/doc/refman/5.0/en/connector-j-reference-configuration-properties.html”,”name”:”MySQL”,”shortName”:”MYSQL”,”supportedAccessTypes”:[“NATIVE”,”ODBC”,”JNDI”]}}], [401]
        2014/09/30 11:04:23 – REST Client.0 – Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)
        2014/09/30 11:04:23 – Abort.0 – ERROR (version 5.0.1-stable.148b6fef6a996547f0a83bc49a869d75ef55b8ca, build 1 from 2013-11-15_14-00-42 by buildguy) : Aborting after having seen 1 rows.
        2014/09/30 11:04:23 – Abort.0 – Finished processing (I=0, O=0, R=1, W=1, U=0, E=1)
        2014/09/30 11:04:23 – _pentahoAddDatasource – ERROR (version 5.0.1-stable.148b6fef6a996547f0a83bc49a869d75ef55b8ca, build 1 from 2013-11-15_14-00-42 by buildguy) : Errors detected!
        2014/09/30 11:04:23 – _pentahoAddDatasource – ERROR (version 5.0.1-stable.148b6fef6a996547f0a83bc49a869d75ef55b8ca, build 1 from 2013-11-15_14-00-42 by buildguy) : Errors detected!
        2014/09/30 11:04:23 – _pentahoAddDatasource – _pentahoAddDatasource
        2014/09/30 11:04:23 – _pentahoAddDatasource – _pentahoAddDatasource
        2014/09/30 11:04:23 – Switch / Case.0 – Finished processing (I=0, O=0, R=1, W=1, U=0, E=0)

  4. Hi Alex,
    It’s a problem during the datasource add into the Pentaho server.
    Probably something is locked. I suggest you to restart the Pentaho server and try to run again the installation.

  5. Hi Alex, I have the same problem: [RepositoryResource] Repository file [:public:AAAR:main.wcdf] not found”. In the instllation procces I see this error: AAAR_Kettle – Couldn’t execute SQL: SET statement_timeout = 0;

    I have Postgres 9.1 in ubuntu 12 TLS.

    ¿Any idea how can I fix it?

    Thanks!

    • Hi Dani,
      Something went wrong during the installation process. And the error says the AAAR_Kettle database was wrongly restored from the SQL script.
      I suggest you to repeat the AAAR installation again (don’t worry about it) because it’s quite strange you get this error. Probably some lock or something wrong in your environment.
      I hope this will help you.

      • Finally I have solved the problem.

        The problem was in AAAR_Kettle_v5.sql script. My Postgres version doesn’t support SET lock_timeout = 0; so I have comment this line and now all is working fine.

        Congratulatios for the nice and thank you very much for sharing it!

Leave a Reply to Dani Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s